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1. Introduction 
This document explains basic configuration of Brekeke PBX. For more advanced setting 

instructions and product information, refer to the Brekeke PBX Administrator’s Guide 

(Advanced). 

 

1.1. Editions 
Brekeke PBX comes in several editions to meet the needs of different users. 

Edition Explanation 

Pro 
Designed for businesses and services needing sophisticated call 

management and advanced features 

Evaluation 
Product trial prior to purchase with Pro Edition’s feature set.  

This license is free of charge. 

Multi -Tenant 
Designed as a platform for providing Hosted IP-PBX service for 

Service Providers.  

 

2. Installation 
2.1. System Requirements 

OS Microsoft Windows XP and later, Linux 

Java 
Java 6 or later (32bit / 64bit)  

 Brekeke products are confirmed to run on Java provided by Oracle Sun Microsystem

Apache Tomcat 

Version 6.x  

 Tomcat install is not required when Brekeke PBX installed with the executable 

installer. 

Memory 512 MB minimum 

 

2.2. Select file to install Brekeke PBX 
 Executable Installer pbx.war (zip format) 

OS Windows OS Linux OS 

Install New Installation only 
New Installation 

Update Installation 

Instruction Section 2.3 (Windows) 
Section 2.4 (Linux) 

Section 2.5 (Update) 
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2.3. Installation for Windows OS with the Executable Installer  
Step 1: Installing Java SE 

Install Java SE before installing the Brekeke PBX software.  

1) Access the website http://www.oracle.com/technetwork/java/javase/downloads/index.html 

2) Download and install the appropriate version of JRE or JDK for the type of Windows OS 

you are running.  

Step 2: Installing Brekeke PBX 

1) Obtain installer file from Brekeke’s website. 

2) Start installation following the installer instructions.  

 Brekeke PBX and bundled SIP server will be installed automatically.  

Step 3: Starting Brekeke PBX HTTP Service 

If you did not check [Run Brekeke PBX 3.0] at the last stage of the installation, start Brekeke 

PBX HTTP Service by the following methods. 

1) From taskbar, open Brekeke PBX Service Manager, and start Brekeke PBX service. 

2) From Control Panel / Performance and Maintenance / Administrative Tools / Services, 

select and start “Brekeke PBX” service. 

3) Restart computer, Brekeke PBX HTTP service will start automatically. 

Step 4: Starting Brekeke PBX Administration Tool (Admintool) 

1) Select Start / Program / Brekeke PBX / Brekeke PBX Admintool 

2) Enter the 16 digit product ID in the given space.  

Entering the same product ID on multiple machines is not allowed. 

3) At the login page, enter User ID and Password. 

The default setting for both administrator user ID and password is sa  

4) Click [Start] button from the menu [Start / Shutdown]. If you see [Active] for status of both 

PBX and the bundled SIP Server, the Brekeke PBX server is started successfully. If you 

see [Inactive], Brekeke PBX server failed to start. 

 

2.4. Installation for Linux OS 
Step 1: Installation of Java SE 

1) Access the website http://www.oracle.com/technetwork/java/javase/downloads/index.html 

2) Download and install the appropriate version of JRE or JDK for the type of OS you are 

running. 

Step 2: Installation of Tomcat 

1) Access the website http://tomcat.apache.org/index.html and download the binary file of 

Tomcat version 6.x for the type of OS you are running.  
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2) Set JRE or JDK installation directory for the environment variable JAVA_HOME. 
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3) Install downloaded Tomcat file. 

 We recommend adding liveDeploy="false" to the server.xml file at Tomcat installation directory/conf/ 

as below . 

<Host name="localhost" appBase="webapps" 

       unpackWARs="true" autoDeploy="true" liveDeploy="false" 

       xmlValidation="false" xmlNamespaceAware="false"> 

Step 3: Installation of Brekeke PBX 

1) Obtain the file pbx.war (zip format file) from Brekeke’s website. 

2) Copy war file directly into the “webapps” directory which is under the Tomcat installation 

directory 

Step 4: Starting Tomcat 

1) Start Tomcat. 

2) Open a web browser and specify http://localhost:8080 as a URL (If you chose a port 

number other than the default “8080”, specify the appropriate port number in the URL.) 

3) Tomcat has started successfully if the Apache Jakarta Project page is displayed. 

Step 5: Starting Brekeke PBX Administration Tool (Admintool) 

1) At web browser, specify the URL http://localhost:8080/pbx/ (If you chose a port number 

other than default “8080”, specify the appropriate port number in the URL.) 

2) Enter the 16 digit product ID in the given space. 

Entering the same product ID on multiple machines is not allowed. 

3) At the login page, enter User ID and Password. 

The default setting for both administrator user ID and password is sa. 

5) Click [Start] button from the menu [Start / Shutdown]. If you see [Active] for status of both 

PBX and the bundled SIP Server, the Brekeke PBX server is started successfully. If you 

see [Inactive], Brekeke PBX server failed to start. 

 

2.5. Updating Brekeke PBX  
This section is for updating from an earlier version of Brekeke PBX v3.x to the current release. 

Please confirm that you have downloaded the update zip file (pbx.war) from Brekeke’s website. 

1) Open [Maintenance] > [Update Software]. 

2) If Brekeke PBX is active, [Shutdown] button is displayed. Click on [Shutdown].  

3) Click the [browse] button to select the pbx.war file you have downloaded. 

4) Click the [upload] button to upload the new file. 

5) Restart your computer to complete updating Brekeke PBX. 

 

 
8  Brekeke PBX Administrator’s Guide (Basic) 
 
p-adm-b3.0_120422 

http://localhost:8080/
http://localhost:8080/pbx


BREKEKE SOFTWARE, INC. 

3. Maintenance 
3.1. Back Up / Restore 

You can back up all of the current configurations and voicemail messages from the Brekeke 

PBX Admintool menu [Maintenance] > [Back Up]. We recommend backing up Brekeke PBX on 

a regular basis. You can restore the backup data from the menu [Maintenance] > [Restore]. To 

backup or restore, shutting down Brekeke PBX is required.  

 

3.2. Activating License 
1) Open [Maintenance] > [Activate License]. 

2) If Brekeke PBX is active, [Shutdown] button is displayed. Click on [Shutdown]. 

3) Read the End User License Agreement (EULA),  

Enter license ID then click on the [Accept terms and activate the license] button next to it. 

If reactivate current license, only click on the [Accept terms and activate the license] button 

at the bottom of [Activate License] page. 

4) If your computer is connected to the Internet, license activation will start automatically. 

If there is not internet access, click on [Get Signature] and follow the instructions shown on 

the screen to activate license. 

5) After completing the activation successfully, you will see the Login screen of Brekeke PBX 

Admintool. 

 

4. Uninstall (Windows OS) 
This topic will assist you with uninstalling the Brekeke PBX software from your computer with a 

Windows OS.  

Navigate to Start / Program / Brekeke PBX / Uninstall Brekeke PBX. The uninstaller will 

uninstall Brekeke PBX automatically.  

 If the uninstaller fails to delete the folder (C:\Program Files\Brekeke\pbx) you will need to restart the 

PC and delete the folder manually.  

 

5. Uninstall (Linux OS) 
Delete the file “pbx.war” and the folder “pbx” in the directory “webapps”, which is located under 

the installation directory of Tomcat, and restart machine. 
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6. Setting Up Brekeke PBX 
6.1. Setting Up Phone Type 

There are three default phone types shown from Brekeke PBX Admintool > [Options] > [Phone 

Type] page when this is the first time Brekeke PBX installation or there is no other phone types 

created when upgraded from previous version. System administrators can also define new 

phone types with various combined settings for RTP relay, codecs and keypad commands. 

 

Depending on system UAs location, codecs and Brekeke PBX feature requirements, user 

clients or system administrators can choose suitable phone type for each Brekeke PBX users 

assigned phones.  

 

6.2. Setting Up User Extensions 
After installing Brekeke PBX, you will need to create users extensions, and assign phone IDs to 

each user extension so that the UAs with assigned phone ID number can call each other and 

apply Brekeke PBX features. 

 

6.2.1. Creating Users 

In this example, user extensions 100 - 105 will be created. 

1) Click Brekeke PBX Admintool > [PBX Admin] > [Extensions] > [Users]. 

Default administrator “sa” has already been created. (Default password is “sa”.)  

2) Click on the [Create a new user] button, user [Account] page will be shown and set as 

following: 

[Extension] 100 

[Login Password] 100 

[Login Password (confirm)] 100 

There is no default user login password. If no login password is set at the time user is 

created, user cannot login its account from Brekeke PBX Admintool. 

3) Change the user account settings as needed 

4) Create other user extensions 101 – 105 as above. 

 

 
10  Brekeke PBX Administrator’s Guide (Basic) 

6.2.2. Default Values of Users 

The following table outlines the default values included with Brekeke PBX users. If you change 

these settings, the functionality of the product may differ from the examples shown in this 

manual. 
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To change user settings, click User ID from [PBX Admin] > [Extensions] > [Users] list, or select 

user from [User] menu on the left panel, and navigate each page under the selected user. 

 

Page Name Setting item Details of default values 

Account Language 
Same language as the 

administrator who created this user

Settings 

Call Pickup group Same group as the administrator 

Greeting message Default system greeting 

Email notification off 

Phones 
Phone 1 > [Phone ID] The same as user ID 

Type Type 1 

Inbound 

Plan Plan 1 (Active) 

Forward To > [Phones] 

All phones are checked by default. 

When there is an incoming call to 

this user, Brekeke PBX will forward 

call to all assigned phones under 

this user. 

Forward To > [Call Forwarding] > 

[Ringer Time (sec)] 
90 seconds 

Forward To > [Call Forwarding] > 

[Forwarding destinations (No 

answer)] 

Forwarded to user’s Voice Mail 

Forward To > [Call Forwarding] > 

[Forwarding destinations (Busy)] 
Forwarded to user’s Voice Mail 

 

6.2.3. Assigning Phones to User Extensions 

For each Brekeke PBX user, up to 4 different phone IDs can be assigned. The default phone ID 

is the same as Brekeke PBX user ID when this user is created and is assigned to [Phone 1] > 

[Phone ID] field 

 

The phone ID can be a SIP UA’s user ID which is registered at Brekeke PBX bundled SIP Server, 
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or a PSTN number which belongs to the owner of this user. The devices with the phone ID 

number assigned under a Brekeke PBX user can apply Brekeke PBX features to the call.. 

 

6.2.4. Voicemail Settings 

After creating the user extensions, you can set up voicemail for each of the users. As described 

in the section above, user 100’s [Forwarding destination (No answer)] and [Forwarding 

destination (Busy)] are set to “Voice Mail” by default. If devices assigned under user 100 do not 

answer after ringing for 90 seconds (or when user 100’s line is busy), the call will be forwarded 

to voicemail. The “vm” prefix is specified under the “mediaserver_prefix” route at the ARS 

settings.  

♦ To leave a voice message directly, dial 07*< user extension ID>. 

♦ To check voice messages from your own phone, dial “8” to reach your voicemail inbox.  

♦ To check voice messages from other phones, dial 08*<your user extension ID> to directly 

access your voicemail inbox. 

 

6.2.5. Voicemail Notification by Email 

Step 1: Setting Up Email Sender 

Brekeke PBX supports mail servers which provide “POP before SMTP” authentication or 

“SMTP” authentication or Encrypted Connection (SSL).  

To set up Email Sender: 

1) Enter the information about your mail server and email user account information at Brekeke 

PBX Admintool [PBX Admin] > [Options] > [Settings] > [Email settings].  

2) Set encrypted connection on or off depending on your mail server type.  

3) Restart Brekeke PBX from Admintool to apply your changes. 

Step 2: Setting Up Email Recipient 

To set up an email recipient: 

1) Navigate to a user [Settings] page by selecting a user from Brekeke PBX Admintool > [PBX 

Admin] > [Users] 

2) Set [Voicemail settings] > [Email address*] to the recipient email address(es) 

3) Set [Voicemail settings] > [Email notification] to “on”. 

4) Set [Voicemail settings] > [Attach WAV file to Email] to “on” or “off” (depending on whether 

you want to attach the voice message to the email or not) 
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6.2.6. Setting Up Call Forwarding 

Call Forwarding is used when users are not available and you want those incoming calls to be 

redirected to another extension or to voicemail. In this example, calls to extension 101 will also 

 
p-adm-b3.0_120422 



BREKEKE SOFTWARE, INC. 

be forwarded to extension 100. 

1) Enter user extension number to which you want to forward the call. In this case, enter user 

extension “100” in user extension 101’s [Other Forwarding destinations*] field. 

2) Make a call to extension 101. Both phones assigned under user extension 100 and 101 will 

ring. 

 

6.2.7. Setting Up No Answer Call Forwarding 

To forward incoming calls to another extension instead of using Voice Mail to answer calls after 

ringer time, set up the forwarding extension in the [Inbound] > [Forwarding destination (No 

answer)] field. 

1) Enter user extension “100” in extension 101’s [Forwarding destinations (No answer)] field 

2) Incoming calls will be forwarded to user extension 100 if user 101 phones do not answer in 

ringer time. 

 

6.2.8. Setting Up Busy Call Forwarding 

To forward incoming calls to another user extension while all phones under a user is “busy”, 

instead of using Voice Mail, set up the forwarding extension in the [Inbound] > [Forwarding 

destination (Busy)] field.  

1) Enter user extension “100” in user extension 101’s [Forwarding destinations (Busy)] field 

2) Calls will be forwarded to 100 if user 101 phones return a 486 Busy response or another 

error response. 

 

6.3. Message Waiting Indicator (MWI) 
If your SIP UA supports MWI with “SUBSCRIBE” message, Brekeke PBX MWI feature will be 

activated with default setting. If there is a special button on your SIP UA to retrieve messages, 

assign a number (default is “8”) to retrieve voicemail messages. Some type of SIP UA can 

automatically call the SIP URI which is specified in Brekeke PBX NOTIFY packet (for MWI) to 

retrieve the message without assigning the number manually. 

 

For those SIP UAs that do not send “SUBSCRIBE” message for MWI, you can set Brekeke PBX 

to send voicemail notification to all PBX users.  

To Enable MWI, set as below and restart Brekeke PBX from admintool.  

[PBX Admin] > [Options] > [Settings] > [Message Waiting Indicator] = on  

Default value is off. 
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6.4. Setting Up Ring Groups .4. Setting Up Ring Groups 
In this example, a Ring Group (1000) is created for all user extensions 101 through 105. When 

calls are received at Group extension 1000, all specified group extensions (101-105) will ring 

simultaneously. If no one answers the call within ringer time (10 sec), the call will be forwarded 

to user extension 100 voicemail box. 

In this example, a Ring Group (1000) is created for all user extensions 101 through 105. When 

calls are received at Group extension 1000, all specified group extensions (101-105) will ring 

simultaneously. If no one answers the call within ringer time (10 sec), the call will be forwarded 

to user extension 100 voicemail box. 

1) From [PBX Admin] > [Extensions] > [Groups], click [Create a new group] 1) From [PBX Admin] > [Extensions] > [Groups], click [Create a new group] 

2) Set as following: 2) Set as following: 

[Extension] 1000 [Extension] 1000 

[Type] Simultaneous Ring [Type] Simultaneous Ring 

[Group Extensions*] 101,102,103,104,105 [Group Extensions*] 101,102,103,104,105 

[Ringer time (sec)] 10 [Ringer time (sec)] 10 

[Forwarding destination (No answer)] vm100 [Forwarding destination (No answer)] vm100 
 

3) Save the setting 3) Save the setting 

  

6.5. Setting Up Call Pickup Group 6.5. Setting Up Call Pickup Group 
Call Pickup is a function that allows users to answer incoming calls to any other user extensions 

by dialing a pre-set number. When a user extension rings, dial * <user extension ID> to answer 

the call. For example, when user extension 100 rings, dialing * 100 will enable you to answer the 

call from any other Brekeke PBX user extension. 

Call Pickup is a function that allows users to answer incoming calls to any other user extensions 

by dialing a pre-set number. When a user extension rings, dial * <user extension ID> to answer 

the call. For example, when user extension 100 rings, dialing * 100 will enable you to answer the 

call from any other Brekeke PBX user extension. 

  

 If you are using a SIP phone that supports a “Call Pickup” button, please consult with the 

manufacturer of your SIP phone on how to set up Call Pickup feature. 

 If you are using a SIP phone that supports a “Call Pickup” button, please consult with the 

manufacturer of your SIP phone on how to set up Call Pickup feature. 

  

Here are some other special ways of using the Call Pickup feature:  Here are some other special ways of using the Call Pickup feature:  

♦ Answer calls that are directed to a Ring Group ♦ Answer calls that are directed to a Ring Group 

Calls directed toward a Simultaneous Ring Group extension can be answered from any 

user extension using Call Pickup. (For details on how to set up a Ring Group, please refer 

to section “Setting Up Ring Groups”) 

Calls directed toward a Simultaneous Ring Group extension can be answered from any 

user extension using Call Pickup. (For details on how to set up a Ring Group, please refer 

to section “Setting Up Ring Groups”) 

  

Extension: 1000 (Simultaneous Ring Group) Extension: 1000 (Simultaneous Ring Group) 

Group Extensions* 101,102,103,104,105 
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Dialing *1000 (Simultaneous Ring Group extension number) enables one to pick up the 

calls and the user extensions in the Ring Group will stop ringing. Incoming calls can still be 

answered by dialing *<user extension ID>, such as *101, *102… However, using the group 

extension does not require you to remember each user extension ID in the group. Dialing 
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*<ring group extension number> feature works even when a call is directly to a single 

extension (e.g. 103), or comes through the Auto Attendant. 

 

♦ One touch Call Pickup for specified Call Pickup Group 

By setting up a Call Pickup Group number (generally a ring group number) in a user 

extension, you only need to dial *(Star) to pickup the incoming calls to any of user 

extensions in the group. You may specify a Call Pickup Group at your user extension’s 

[Settings] > [Call Pickup group], such as, 1000. 

 

When there is an incoming call to any user extensions, 101 – 105, in Simultaneous Ring 

Group extension 1000 > [Group Extensions] field, you can answer the call by dialing * 

(Star) only. 

 

6.6. Setting Up Call Hunting 
Here is how to set up Call Hunting: 

1) From [PBX Admin] > [Extensions] > [Groups], click [Create a new group] 

2) Set as following: 

[Extension] 1001 

[Type] Call Hunting 

[Mode] Round robin / Top-down 

[Hunt group extensions*] 101,102,103,104,105 

[Ringer time (sec)*] 5 

[Waiting time in the queue (sec)] 120 

[Max number of calls in the queue] 10 

[Call interval (msec)] 3000 

[Single attempt] no 

[Forwarding destination (No Answer)] 100 

3) Save the setting 
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In this example, the call will ring the user extensions in [Hunt group extensions*] field one by one 

with waiting time [Ringer time(sec)](5 sec) interval between calling each user extension. When 

all of the group extensions (101-105) are busy or do not answer, the call will be queued. If any 

member becomes available within the interval set in [Waiting time in the queue (sec)], Brekeke 

PBX will ring the available members one by one with waiting time [Call interval (msec)](3000 

ms) to ring next group extension after previous user ringing times out. If all members continue to 

be busy after the specified interval at [Waiting time in the queue (sec)], the call will be forwarded 
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to the destination set in [Forwarding destination (No answer)]. In this example, the call will be 

forwarded to user 100. 

 

The music on hold, which caller is hearing when waiting in queue, can be changed by uploading 

new sound file from [Sound files] > [Music on hold] field. 

 

6.7. Setting Up Auto Attendant 
The example below shows Auto Attendant for extension 1002. 

1) From [PBX Admin] > [Extensions] > [IVR], click [Create a new IVR] button 

2) Set as following: 

 [Extension] 1002 

 [Type] Auto Attendant 

 [Max input digits] 3 

 [Max retry count] 5 

 [Ring timeout (sec)] 10 

 [Default operator] 100 

 [DTMF timeout (sec)] 20 

 [Transfer to unregistered users] disable 

3) Save the settings 
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In this example, the incoming call to Auto Attendant 1002 will hear default greeting voice prompt 

for user extension input.  

 

If there is no input in 20 sec ([DTMF timeout (sec)]), Brekeke PBX will ask for re-inputting user 

extension. After 5 times of no extension input ([Max retry count]), the call will be forwarded to 

destination set at [Default operator] field. 

 

If caller input extension numbers, the call will be transferred to the user extension whose ID is 

the same as the first 3 digits ([Max input digits]). If transferred recipient does not answer call 

within 10 sec ([Ring timeout (sec)]), Brekeke PBX will stop ringing input user extension and Auto 

Attendant will ask for inputting another extension number. 

 

When [Transfer to unregistered users] is set to enable, caller can apply Brekeke PBX features 

from Auto Attendant, such as accessing voicemail box, call pickup, call monitoring and so on. 

Proper value needs to set at Auto Attendant > [Max input digits] field to allow caller’s input.  
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Optionally, an audio file for Auto Attendant greeting can be uploaded from Auto Attendant > 

[Sound files] section. 

 

6.8. Setting Up Call Forwarding Schedule 
This feature is useful for creating rules for call forwarding during specified times. In this example, 

incoming calls to Schedule extension 5555 during business hours are directed to the Auto 

Attendant at extension 1002. After business hours, callers are scheduled to hear “To speak with 

a live operator, please call during regular business hours. Our regular business hours are 

Monday through Friday, 9 a.m. to 6 p.m.” 

 

The following settings can be used to set up such a scenario.  

1) Create an Auto Attendant 1003 and upload after business hour greeting to [Greeting 

messages] under Auto Attendant 1003 

2) From [PBX Admin] > [Extensions] > [Schedule], click [Create a new schedule] button 

3) Set as following: 

 [Extension] 5555 

 [Default Forwarding Schedule] > [Call forwarding] > [Destination] 1003 

4) Click on [Add Forwarding Schedule] button 

 Set under [Forwarding Schedule 1] as following: 

 At [Forward To] > [Call forwarding] > [Forwarding Destination] field, set 1002 

 Click on [Conditions] tab, set [Date/Time] section as following 

 [Term] set Schedule starting and ending Date and Year 

 [Days] Check 1st- 5th and Monday through Friday  

 [Time] select and check 9:00 - 18:00 

5) Save the settings 
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6.9. Setting Up Switch Plan 
Switch Patterns can be used to temporarily and quickly change a user’s forwarding destination 

by setting different forwarding schedule plan as active. 

 

In this example, incoming calls during business hours go directly to user 100 assigned phones. 

However, during user 100’s lunch break, user prefers incoming calls to go directly to voicemail. 

User 100 can enter DND (Do Not Disturb) mode by switching between pre-defined inbound 

plans to route incoming calls to his voicemail temporarily during lunch time.  

We can achieve this by using a Switch Pattern as described below. 
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Step 1: Setting Up Switch Plan extension 

1) From [PBX Admin] > [Extensions] > [IVR], click [Create a new IVR] button 

2) Set as following: 

[Extension] 1004 

[Type] Switch Plan 

[Plan number] 2 

[on/off] yes 

3) Save the settings 

Step 2: Setting Up Plans in user extension 

1) From User 100 > [Inbound] page, click [Add new plan] button 

“Plan 2” will show in the plan drop down list window  

2) Uncheck all phones list in Plan 2 and set [Other Forwarding Destinaitons*] as vm100 

3) Save the settings 

Step 3: Enter Do Not Disturb Mode 

1) User 100 dial Switch Plan extension 1004 from his phone to enter DND mode 

At user 100 > [Inbound] page, Plan 2 will be set as active  

2) Any calls to user 100 at this time will be directed to user 100 voicemail inbox. 

Step 4: Remove Do Not Disturb Mode 

1) User 100 dial Switch Plan extension 1004 from his phone again to remove DND mode. 

At user 100 > [Inbound] page, the plan before entering DND mode will be set as active 

again. 

2) After resuming from DND mode, any calls to user 100 will be directed to his/her assigned 

phones. 

 

6.10. Setting Up Conference Call 
6.10.1. Creating a Conference Room 

The first step to using the Conference Call feature is to set up a Conference Room. In the 

following example, user 2000 is set up as the conference number. 

 

 If you are using SIP phone that support “Conference Call” button, please consult the manufacturer of 

your SIP phone for how to set up Conference Call feature. 

 

1) From [PBX Admin] > [Extensions] > [Conference], click [Create a new conference] button   

2) Set as following: 

[Extension] 2000 

 
18  Brekeke PBX Administrator’s Guide (Basic) 

 Leave all other settings as default 
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3) Save the settings 

With the above settings, any user can enter in the conference room by dialing 2000. 

 

6.10.2. Limiting Members Who Can Enter the Conference Room 

You can limit members that join the conference by specifying members (for example 

“101,102,103”) at [Applies to (Caller numbers)*] field. With this setting only user 101, 102, 

and 103 will be allowed to join the conference. Any other users,cannot join this conference 

room. 

 

6.10.3.  Simultaneous Calls to All of the Conference Members 

A conference member can convene all members of the conference room at once. For example, 

set 101, 102, 103 at [Forwarding destinations*]. By dialing 2000, all conference members 

(101, 102, and 103) will be invited simultaneously. 

 

6.10.4. Starting a Conference Call (Alternate Methods) 

Additional methods for starting a conference call are described in the Brekeke PBX Users 

Guide. 

 

6.11. Setting Up Callback 
With callback feature, Brekeke PBX will ring caller back when caller dial to Callback user. In the following 

example, user 3000 is set up as Callback extension. 

1) From [PBX Admin] > [Extensions] > [Callback], click [Create a new callback] button 

2) Set as following: 

[Extension] 3000 

[Ringer time (sec)] 90 

[Forwarding destination (No answer)] 100   

[Callback callee] 1002 

3) Save the settings 
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When caller dial to Callback extension, caller will hear ring tone. If caller hangs up call before 

ringer timeout, Brekeke PBX will send INVITE to caller back and caller will be directed to 

destination set in [Callback callee] field when original call answer the call. In this example, caller 

will be connected to Auto Attendant 1002. 

If caller who dial to Callback extension does not hang up call and ringer timeout, the call will be 

directed to the destination set in [No answer forwarding destination] field 
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6.12. Setting Up Confirm Call 
1) Go to Brekeke PBX Admintool > [PBX Admin] > [Voice Prompts] and upload an audio file  

named "confirmcall", which will play voice prompt to let call recipient to press confirm key to 

establish call. 

2) Go to Brekeke PBX Admintool > [PBX Admin] > [ARS] and create a new ARS Route to use 

Confirm Call or add Confirm Call setting to an existing ARS outbound route. 

3) At "Patterns – OUT" in the ARS Route, set value to "Confirm" parameter under [Deploy 

patterns]. You need to enclose the value of the "Confirm" parameter with curly brackets, "{" 

and "}". In this example, at [Confirm] field set as {confirmcall} 

4) Specify the confirm key. at [Key] field next to [Confirm] field . The default key is 5. 

5) Making outbound calls by applying the ARS route with confirm call setting. When call 

recipient answer the call, he/she will hear confirm voice prompt first. If call recipient 

presses the confirm key (5) from his phone keypad before voice prompt ends, the call will 

be established between caller and callee. Otherwise, Brekeke PBX will disconnect the call. 

 

 If set {confirmcall}{name:&f1} in [Confirm] field, callee can hear caller’s name (if available) or caller’s 

phone number after the voice prompt. In this case, you need to set [From] in the Matching patterns, 

e.g. sip:(.*)@ 

 

6.13. Setting Up Paging 
The phones which support paging will answer incoming calls automatically without taking the 

handset off-hook when these phones receive the paging information sent in the SIP header from 

Brekeke PBX. 

 

A list of SIP phones that work with Brekeke PBX paging function and its sample configuration 

are available at Brekeke Wiki http://wiki.brekeke.com/wiki/paging-function_phone-list 

 

6.14. Setting Up Busy Lamp Field, Presence, and Shared Call Appearance 
♦ BLF (Busy Lamp Field)  

With BLF, when there is a call to the monitored phone, the corresponding key lamp on the 

monitoring phone will flash and the call can be picked up from the monitoring phone. 

♦ SCA (Shared Call Appearance) 

With SCA, users can monitor the external line status and select an available line to place an 

outbound call or answer the incoming calls. 
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♦ Presence  

With presence, Brekeke PBX can handle presence SUBSCRIBE requests from phones, 
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and return NOTIFY responses about the status of the monitored phones such as "available" 

or "on the phone". 

 

A list of SIP phones that work with these function and its sample configuration are available at 

Brekeke Wiki http://wiki.brekeke.com/wiki/BLF-SCA-and-Presence. 

 

6.15. ARS Settings 
For more information about the ARS feature, please refer to Brekeke PBX Administrator’s Guide 

(Advanced). 

♦ General 

Use [General] section to enable or disable ARS template and settings required by some 

Brekeke PBX features, such as, Shared Call Appearance, ARS group, call logs database 

for billing and so on. 

♦ Registration 

- Register VoIP gateway port SIP number at Brekeke PBX bundled SIP Server, Brekeke 

PBX will accept calls from this gateway even if the gateway is not registered at Brekeke 

PBX bundled SIP Server. 

- When making outbound calls from UAs to an ITSP through Brekeke PBX and provider 

needs authentication information from caller, Brekeke PBX will send user and password set 

in this section to provider IP or domain set in [Proxy Address] field. 

♦ Patterns 

Define Patterns IN and OUT to receive and send calls from/to SIP devices and services. 

♦ Priority 

It is useful to set priority when there are multiple options for making calls, such as when you 

have multiple PSTN gateways for outbound calls or when you subscribe to multiple VoIP 

service providers. Lower numbers hold the higher priorities  
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♦ Max Sessions 

Setting “-1” specifies an unlimited number of sessions. Set [Max Sessions] field to define 

the maximum sessions that can be handled by each pattern, such as when there is a 

limited number of Gateway channels or subscribed lines for SIP services. 

For the ARS routes in the same group, there is only one session counter. The session 

counter will increase 1 when there is a call through ARS route no matter Pattern IN or OUT. 

If this session counter is equal to any [Max Sessions] value set in the ARS routes in the 

same group, the next matched session cannot apply to this pattern (IN or OUT), or any 

ARS routes when all patterns’ [Max Sessions] of the ARS routes in the same group are set 

the same value. 
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♦ Edit Variables 

Variables Default value 

v1 User ID/Number 

v2 Password 

v3 – v9 Customizable fields 

 

6.16.  PSTN Access Using a VoIP Gateway 
Using a SIP compliant VoIP Gateway, Brekeke PBX users can receive calls from Public 

Switched Telephone Network (PSTN) and make calls to PSTN lines. 

 

6.16.1. VoIP Gateway Setup 

Set the following at your VoIP Gateway: 

SIP proxy address IP address of Brekeke bundled SIP server 

Dialing number sent to Brekeke PBX PSTN line number 

 

6.16.2. ARS Route Setup 

Setup “Patterns - IN” and ”Patterns – OUT” in Gateway ARS Route to receive and make calls 

from/to the Gateway. 

 

Set as following to register the gateway at the Brekeke PBX bundled SIP server. Many PSTN 

Gateways have a short interval between sessions during which the line is unavailable. Modify 

[Session interval (ms)] field setting to reflect this delay as needed.  

[Registration] 

Register URI sip:&v1@127.0.0.1 Register Expire (sec) 3600 

Proxy Address 127.0.0.1 Register Update Period (%) 90 

User  Password   

 

6.16.3. Receiving PSTN Calls 

Create Gateway ARS Route “Patterns – IN” to receive calls from a gateway 

Patterns - IN 

 Matching patterns Deploy patterns 

From  

To sip:&v1@ &v3 
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Click the [Edit Variables] link at upper-right corner of ARS Route page 

v1 v2(password) v3 

PSTN line number set at 

Section “VoIP Gateway 

Setup” 

(leave blank) 
Specify a Brekeke PBX 

extension number 

 

6.16.4. Calling PSTN Numbers 

One Stage Dialing 

If your VoIP Gateway supports One Stage Dialing, a Brekeke PBX user can make a PSTN direct 

call by setting an ARS Route as follows: 

Patterns - OUT 

 Matching patterns Deploy patterns 

From  

To sip:([0-9]{7,25})@ sip:$1@gw_IPaddress 

 

In this example, Regular Expressions were used to define the Matching and Deploy patterns. A 

Brekeke PBX user dials a number, whose digits are between 7 and 25, will be considered as a 

PSTN call. Brekeke PBX will apply the above ARS Route and the call will be sent to gateway. 

If you have multiple VoIP Gateways used for outbound calls, define more detailed dialing pattern 

in [Matching patterns] > [To], and change [Priority] field as your need to define the usage order 

of Gateways. Please note lower numbers hold higher priorities. And use [Max Sessions] field to 

define the total sessions handled by each pattern. 

 

Two Stage Dialing 

If your VoIP Gateway supports Two Stage Dialing, have the gateway’s PSTN port register with 

Brekeke PBX bundled SIP server. Let us suppose the gateway’s PSTN port has the SIP user 

name, 111. To call a PSTN number, dial the gateway’s PSTN registered port number (in this 

example, it is number 111) and then dial the destination PSTN number, or configure DTMF 

setting at ARS Route OUT pattern so that the dialed numbers will be sent to gateway as DTMF 

tones.  

 

The OUT pattern to send destination number by DTMF in two stage dialing is shown as below: 

Patterns - OUT 

Matching patterns Deploy patterns 

From  From 
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To sip:111(.+)@ To sip:111@gw_IPaddress 

  DTMF $1 

 If delay is needed before sending DTMF, set [DTMF] field as {file_name}$1. Default files are {1sec}, 

{2sec}, {120ms}, {240ms}, and {500ms}. Customized files can be uploaded from Brekeke PBX 

admintool > [PBX Admin] > [Voice prompts] and set [Language]: Common. 

 

6.17.  Connecting with Internet Telephony Service Providers (ITSPs) 
6.17.1. Account Information for Third Party SIP Server 

Acquiring the information shown below is necessary to connect with a third party SIP server.  

Phone number 6504106636 

SIP server IP address sample_proxy.com 

User ID 6504106636 

Password 6636 

 

 

 Depending upon the provider there may be restrictions for connecting to services, such as available 

information or equipment used to connect. Please contact your VoIP service provider for more 

details. 

 Please note that we do not guarantee connection with third party products.  

 

6.17.2. Setting ARS for ITSP using multiple accounts 

[Registration]. 

Field 

Name 
Sample Settings Explanation 

Register 

URI 
sip:&v1@sample_proxy.com Enter SIP URI  

Proxy 

Address 
sample_proxy.com 

Can be omitted when the Proxy address is 

the same as the one in [Register URI] field 

User &v1 Set value at [Edit Variables] page 

Password &v2 

Set value at [Edit Variables] page  

This field will be displayed in text format 

after saving. 

 

[Patterns – IN] 

In the pattern-IN example below, Brekeke PBX user extension 100 (&v3 value, set at [Edit 

Variables] page) is set to ring when a call comes through the third party SIP server. Leaving the 
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“From” field blank carries over the Caller ID information.  

 

 Matching patterns Deploy patterns 

To sip:&v1@ &v3 

 Check [Apply to Request URI instead of To] when To header sent from ITSP is different from To 

defined in the ARS Route Patterns – IN. 

 

[Patterns – OUT] 

Patterns - OUT defines patterns for converting SIP URI to match your VoIP provider’s header 

format requirements. In the example below, dialed numbers with 7 to 25 digits will be directed 

through the VoIP service provider. To ensure that the recipient’s caller ID display will function, 

the “From header” will be changed according to the rules of the provider. Set [Priority] and [Max 

Sessions] as you need. 

 

 Matching patterns Deploy patterns 

From  “&v1”<sip:&v1@sample_proxy.com> 

To sip:([0-9]{7,25})@ sip:$1@sample_proxy.com 

 Some VoIP service providers restrict the connection when FROM or TO header information is 

different from their own header format. 

 

[Edit Variables] 

Click the [Edit Variables] link at upper-right corner of ARS Route page 

v1 v2(password) v3 

6504106636 6636 100  

 

6.18. ARS Outbound Route Failover 
Utilizing the Automatic Route Selection (ARS) outbound route failover feature allows users to 

create redundant telecommunications systems. If an outbound route is not available or usable, 

Brekeke PBX will fail over the session to an alternative route. 

 

6.18.1. Usage Examples 

♦ Brekeke PBX provides automatic failover to alternative ITSP service in the event of failure 

at your specified ITSP service. 

♦ Brekeke PBX provides automatic failover to analog telephone session via PSTN Gateway 

in the event of failure at your specified ITSP service. 
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♦ Creating redundant analog telephone connections with multiple PSTN Gateways. 

 

6.18.2. Setting Examples 

The ITSP line is set for regular outbound sessions. When the ITSP line fails, the outbound 

sessions will be routed through PSTN Gateway. 

 

In the following example, two ARS routes are created, “ITSP_A” and “MyGateway”. The route 

with highest priority “ITSP_A” will be used for outbound calls with 7 to 25 digit dialing number. If 

there is no response within 4 seconds (Response timeout: 4000 ms) for INVITE messages or 

“500-599” response was received, Brekeke PBX will continue searching next route matching 

outbound session request. And the next highest prioritized route “MyGateway” will be chosen for 

the alternative route for the session. Since the recovery time is set for one hour (3600000 ms) in 

“ITSP_A”, the matching sessions will be routed through route “MyGateway” for one hour after 

the failover. If “ITSP_A” is back on running in an hour, the sessions will be routed through the 

highest priority route, “ITSP_A” again.  

 

Route name: ITSP_A  

Patterns - OUT 

OUT - 1 Matching patterns Deploy patterns 

Priority 1 From  From “xxx”<sip:xxx@itsp.com> 

Max 

Sessions 
4 To sip:([0-9]{7,25})@ To sip:$1@itsp.com 

 

 

 

 

 

 

 

 

 

Parameters 

Next route on 

failure 
Yes 

Disable on 

registration 

failure 

Yes 

Response 

timeout (ms) 
4000 Error codes 500-599 

Recovery 

time (ms) 
3600000 

Disable on 

failure 
This route 

 

♦ [Response Timeout (ms)] should be adjusted according to your environment. For PSTN 

Gateways and SIP servers located in the local network may not require setting long 

Response Timeout intervals. For the route that requires an internet connection or if a delay 

is expected, the Response Timeout intervals should be set longer.  
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♦ [Disable on registration failure] is set as “yes” in Route “ITSP_A”. When registration is not 

working property at “ITSP-A” route, it will be disabled and “MyGateway” route will be used 

instead.  

♦ [Disable on failure] is set as “This route”. It will disable whole route. If there are other 

IN/OUT patterns defined in this route, they will be unusable when failover happens. Set as 

“This pattern” will only disable the current pattern and other patterns in this route will still be 

usable. 

 

Route name: MyGateway  

Patterns - OUT 

OUT - 1 Matching patterns Deploy patterns 

Priority 100 From  From  

Max 

Sessions 
4 To sip:([0-9]{7,25})@ To sip:$1@GW_IPaddress 
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7. Setup Items 
7.1. Start/Shutdown 

At start/shutdown page, system administrator can check Brekeke PBX and its bundled SIP 

Server running status, current events like ARS route registration history, and restart or shutdown 

Brekeke PBX and bundled SIP Server. 

 

7.2. Options 
The following list displays the settings under the [Options] menu. This menu is only available to 

system administrators. 

 

7.2.1. Settings 

♦ General Settings 

Name Default value Description 

Start up Auto 

Auto: Brekeke PBX starts up automatically with 

Tomcat (Brekeke PBX HTTP Service).  

Manual – Start up manually.  

Options: Auto/Manual  

 

 

♦ PBX System Settings 

Name  Default value Description 

Call pickup prefix * Prefix for picking up calls  

Port number 5052 
The port number that Brekeke PBX will use. 

Modify as needed to avoid port confliction  

Max concurrent 

sessions 

Depends on 

license 

The maximum number of concurrent sessions that 

Brekeke PBX can handle. (Cannot be modified) 

Max number of 

UAs (User Agents) 

Depends on 

license 

The maximum number of SIP UAs that Brekeke 

PBX can handle. (Cannot be modified) 

Min Port 30000 
Minimum port number the RTP Protocol uses for 

sending voice data. Adjust setting as needed 

Max Port 49999 
Maximum port number the RTP uses for sending 

voice data. Adjust setting as needed 

RTP relay on 
on – RTP is handled by Brekeke PBX. 

off – RTP is not handled by Brekeke PBX. 
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(Applied unless there is different RTP relay setting 

specified at the User phone type or ARS Routes) 

Codec priority 0 

G.711 u-law (PCMU) is used by default. Separate 

with comma (,) when specifying multiple payloads. 

The following payload type can be used at the 

Brekeke PBX: 

0 - G.711 u-law 

8 - G.711 A-law 

18 - G.729 

98 - iLBC 

If Codec priority is not set in ARS Routes or user 

phone type setting, this setting will be applied. 

Use Remote 

Preferred Codec 
no 

Use codec setting that is preferred at the remote 

SIP UA. If “default” is set in [Use Remote Preferred 

Codec] in ARS or user phone type, this setting will 

be applied. 

Max concurrent 

recording 

sessions 

10 Maximum concurrent sessions with call recording  

Ringing Timeout 

(ms) 
240000 

Timeout value for awaiting an answer from the 

dialed party after ringing starts. 

Talking Timeout 

(ms) 
259200000 

The maximum length of time a call can last in 

talking. When no other SIP packets are received for 

a period of time. Value 0 signifies infinite. 

Max hop number 20 
Maximum number of SIP servers or Brekeke PBX 

that a call can go through (hop number). 

Days to keep call 

logs 
90 Number of days to keep call logs 

Session Timer 

(sec, 0=disable) 
0 

Interval to allow both UAs and SIP server to 

determine whether the SIP session is still active. 

Session Keep 

Alive (sec) 
600 

Interval to send keep-alive packets to UAs during a 

call when RTP relay is set to off and session timer 

has not been used 

RTP Session 

Timeout (ms) 
600000 

Timeout value for Brekeke PBX awaiting the next 

RTP packet 
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100rel off 
Enable (on) / Disable (off) on using reliable 

provisional responses (1xx series) 

RFC2833 on 
Enable (on) / Disable (off) RFC2833 setting 

Available 

Valid client IP 

Pattern 
 

web service security -- used by Brekeke PAL and 

Brekeke Web Service; set with regular expression 

Java VM 

arguments  
 Parameters passed to VM  

 

♦ Media Server System Settings 

Name  Default value Description 

Port number 5056 
The port number that Media server system uses. 

Modify as needed to avoid port confliction 

Max concurrent 

session limit 

Depends upon 

the license 

Maximum number of concurrent sessions for Media 

server. ( cannot be modified.) 

Codec priority 0 

G.711 u-law (PCMU) is used by default. Separate 

with comma (,) when specifying multiple codecs. 

See also the description for [Codec priority] 

Use Remote 

Preferred Codec 
no 

Enable (no) / Disable (yes) on using remote codec 

used by the endpoints. 

Max stored 

messages 
50 

Maximum number of saved voicemail messages 

and any recorded file for each user’s voicemail. 

Message 

recording length 

(sec) 

600 

Maximum length of recording time for a voicemail 

message. If [Message recording length (sec)] in 

User setting is blank, this value will be applied. 

Days to keep 

unsaved 

messages 

30 

The number of days before unsaved messages is 

deleted automatically from each user’s voicemail 

inbox. 

Message Waiting 

Indicator 
off 

Enable(on) / Disable(off) Message Waiting Indicator 

(Voice mail notification to phones) 

Conversation 

recording length 

(sec) 

3600 Maximum recording length for each call. 

Min Port 50000 
Minimum port number the RTP uses for sending 

voice data. 
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Max Port 59999 
Maximum port number the RTP uses for sending 

voice data. 

Ringing Timeout 

(ms) 
240000 

Timeout value for awaiting an answer from the 

dialed party after ringing starts. 

Talking Timeout 

(ms) 
259200000 

Timeout value for canceling a session. The timeout 

value is calculated after the last SIP session 

received while session is in talk. 

RTP Session 

Timeout (ms) 
600000 Timeout value for awaiting the next RTP packet  

Java VM 

Arguments 
 Parameters passed to VM  

 ms = 0.001 second 

 

♦ Email Settings 

Name Default value Description 

SMTP Server  

The SMTP server Address for sending email 

notifications when the user receives a new 

voicemail message. 

SMTP Port 25 SMTP server’s listening port 

SMTP 

authentication 
on 

Enable (on) /Disable (off) SMTP authentication 

setting 

Encrypted 

Connection (SSL) 
off 

Enable (on) /Disable (off) Encrypted Connection 

(SSL)  Available since version 2.3 

POP3 server  
The address of the POP3 server. (for 

POP-before-SMTP authentication) 

POP3 Port 110 POP3 server’s listening port 

User  
email account user name for the above SMTP 

server. 

Password  email account password 

Password 

(confirm) 
 Input field for confirming the above password. 

Email address 

(from) 
 Email notifications sender’s address.  

Email subject 
voicemail({to}) 

: from {from} 

E-mail Subject for the e-mail notifications. 

The following variables can be configured. 
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{from}: SIP URI who left the voicemail message 

{to}: voicemail box’s SIP URI 

{from-number}: number in {from} 

{to-number}: number in {to} 

{time}: time when the messaged is recorded. 

{recording-length}: time length of the recorded 

message 

Email body 

from:{from} 

to:{to} 

time:{time} 

recording 

length(sec):{re

cording-length 

Email body for the e-mail notifications. 

Variables can be used in this field are the same as 

[Email subject] (See above). 

 

♦ PAL Settings 

Name Default value Description 

Notification for 

Registration 
Yes 

Send notification to PAL application or not when a 

user phone has registered. 

 

7.2.2. User Access Settings 

Restrict the features those are displayed and can be modified from User account when User log 

into Brekeke PBX Admintool 

 

7.2.3. Phone Type 

Name Default value Description 

Type Name 

Type 1 

Type 2 

Type 3 

 

The default phone types which can be chosen from 

User extension > [Phones] page [Type] field. 

Default setting Type 1 

Description  Describe phone type 

RTP relay Default/off 

When set as default, user phones assigned with this 

phone type will apply the RTP relay setting the same 

as the RTP relay setting in [Options] menu. 

When set as off, Brekeke PBX will not relay RTP for 

the user phones assigned with this phone type. 
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Codec Priority  

The default setting will apply [Codec Priority] setting 

in [Options] menu. 

Brekeke PBX will first apply the [Codec Priority] 

setting in phone type assigned to user phones if the 

setting in phone type is different from the settings in 

[Options] menu. 

Use Remote 

Preferred Codec 
Default 

Set as default, the setting in [Options] menu will be 

applied. 

Brekeke PBX will first apply the setting in phone 

type assigned to user phones if the setting in phone 

type is different from the settings in [Options] menu. 

Keypad 

Commands 
On/off 

Set as on, the phones assigned under user 

extension can use Brekeke PBX keypad command, 

such as #9, #8 

Set as off, the phones assigned under user 

extension cannot use Brekeke PBX keypad 

command 

Properties  
Set properties which do not have corresponding 

fields in the Brekeke PBX Admintool 

 

7.2.4. Auto Sync 

[Auto Sync] menu is used for Brekeke PBX redundancy setup. This feature requires a license 

upgrade. 

 

7.2.5. Advanced 

The menu item [Options] > [Advanced] allows you to set properties which do not have 

corresponding fields in the Brekeke PBX admintool. Please refer to other manuals and tutorials 

regarding the type of properties that may be edited here. 

 

7.3. Voice Prompts 
 

7.3.1. System Voice Prompts 

Upload customized sound file to overwrite system default sound file or use as needed. A list of 

Name, Language, and Description will display. 
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Name Description 

Language Choose folder to save uploaded files 

Name 

The name for the uploaded files in the folder  

If file name is the same as system default sound files, the uploaded 

sound file will be played. 

Description A memo shown on the GUI for the file usage 

File Name 

To upload a file, click the [Browse] button.  

Select the file you want to upload and click [Upload].  

The upload will then start 

Download 
To download a recorded sound file, click Download ( ). The file will 

be downloaded to your PC as a WAV file. 

Delete 
To delete the recorded sound files, click Delete ( ). The selected 
files will be deleted. 

 

7.3.2. Notes for Sound Files 

Uploaded sound files must be formatted as below. 

Sample rate 8 kHz 

Bit-Depth 16 bit 

Channels Mono 

 

You may use sound recording applications, such as Windows Microsoft Sound Recorder. We 

recommend that you adjust the pause and sound level to suit your needs and requirements. 

 

7.4. Automatic Route Selection (ARS) 
Brekeke PBX automatically selects the optimum call route from preset routing options. This 

feature can be used for Least Cost Routing, traffic management, and load balancing of VoIP 

Gateways or PBXs.  

 

7.4.1. Adding a New Route 

To add a new route:  

1) Choose [ARS] > [Settings] > [New Route] from the submenu. 

2) Type the name of a Route in the input field on the new popup window. 

3) Click [OK] to add the route. 
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7.4.2. Editing, Copying, or Deleting a Route 

To edit/copy/delete a route:  

1) Select [ARS] > [Settings] from the submenu. 

2) Uncheck [Hide Disabled Rules] and [Hide Details] to show all ARS Routes and details  

3) Click on ARS route name to edit a route 

4) Choose copy, or delete icon to complete related actions. 

 

7.4.3. Viewing an Active Route 

To view an active ARS route:  

1) Choose [ARS] > [Running Status]. 

2) Uncheck [Hide Details] to show details about each Route 

3) Click on route name to show the details about the active route 

If no ARS route is enabled, there will be no route displayed under [Running Status]. Select 

[Settings] will display all ARS Routes. 

 

7.4.4. ARS > Route Template 

♦ General 

Name Default value Description 

Route name  The name for the route 

Description  The description for the route 

Disabled checked Disable / enable the ARS route  

Type Type A Used for special occasions 

Group  ID for a group of ARS Routes  

External Unchecked 
When checked, Brekeke PBX will recognize this 

ARS route as external line.  

LineKey unchecked Check if you use Line keys. (Optional feature) 

Session interval 

(ms) 
 

Set interval period between sessions for some VoIP 

FXO Gateways that require pausing between 

sessions. 

Apply this route 

for incoming calls 
Yes 

This setting takes effect when there is registration 

setup in the same route. 

If set as yes, the incoming calls will apply this ARS 

route only when INVITE request URL is the same as 

that in the contact header of REGISTER request 

sent by this route. 
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♦ Registration 

Name Default value Description 

Register URI  

SIP URI that is used to register Brekeke PBX at 

remote registrar server. Leave this blank when there 

is no need to register Brekeke PBX to any remote 

registrar server. 

Proxy Address  

IP address of the registrar server. This field is 

optional when the proxy address is the same as the 

address set in the Register URI field. 

Register Expire 

(sec) 
3600 Set REGISTER expires.  

Register Update 

Period (%) 
90 

The percentage value of the interval until re-register 

occurs is calculated from the length specified in the 

Register Expire setting. 

User  
User ID for authentication account. Entry is not 

necessary when authentication is not used. 

Password  
Password for authentication account. Entry is not 

necessary when authentication is not used. 

 

♦ Pattern - IN 

Name 
Default 

value 
Description 

Priority 100 Lower numbers hold a higher priority.  

Max Sessions -1 

Specify the number of sessions 

(including RINGING and BYE 

sessions) that are allocated to the 

route. 

Disabled unchecked Enable/Disable this pattern 

Matching patterns From  

Specify a matching rule for From 

header using regular expressions. 

When the field is left blank, all calls will 

be considered as matched. 
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To  

Specify a matching rule for To header 

using regular expressions. When the 

field is left blank, all calls will be 

considered as matched. 

Plugin  The java class name for the plug-in 

Param  
The parameters which will be used by 

the plug-in 

Return  
The pattern of the value returned by the 

plug-in 

Apply to 

Request URI 

instead of To 

unchecked 

If checked, compare the Request URI 

instead of To header Mostly design for 

using ITSP accounts.   

 

Apply only to 

calls related to 

registration 

unchecked 
If checked, the route only apply to the 

calls related to registration. 

Deploy patterns 

From  
Specify replace patterns for From 

header using regular expressions. 

To  
Specify replace patterns for To header 

using regular expressions 

Custom  Used for special occasions 

Parameters 

RTP relay default 

Select RTP relay ON/OFF.  

If “Default” is selected, the setting is the 

same as [Options] > [RTP relay]. 

(Unless specified at the User settings) 

on – RTP is handled by PBX. 

off – RTP is not handled by PBX. 

Codec Priority  

Specify codec to be used. Use a 

comma (,) when specifying multiple 

payload. The following payload type 

can be used at the Brekeke PBX: 

0 - G.711 u-law 

8 - G.711 A-law 

18 – G.729 

98 - iLBC 
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Use Remote 

Preferred 

Codec 

default 

Enable (on) / Disable (off) on using 

remote codec used by the endpoints. 

“default”: remote codec setting in 

[Options] setting will be applied. 

Block SIP 

INFO (DTMF) 
no 

Block or pass-through the SIP INFO 

(DTMF) from a user to the other party 

Send RTCP off 
off - PBX will not handle RTCP packets 

on – PBX will handle RTCP packets 

SDP 18x  default 

“default”: depend upon the situation of 

how sessions are established 

“block”: remove SDP 

“append”: attach SDP.  

If SDP is not included in packets, 

Ring-Back Tone will be played by 

Brekeke PBX. 

 

♦ Patterns - OUT 

Name 
Default 

value 
Description 

Priority 100 Lower numbers hold a higher priority.  

Max Sessions -1 

Specify the number of sessions 

(including RINGING and BYE 

sessions) that are allocated to the 

priority. 

Disabled unchecked Enable/Disable this pattern 

Matching patterns 

From  

Specify a matching rule for From 

header using regular expressions. 

When the field is left blank, all calls will 

be considered as matched. 

To  

Specify a matching rule for To header 

using regular expressions. When the 

field is left blank, all calls will be 

considered as matched calls. 
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User ^.+$ 

Mostly designed for multiple ITSP 

accounts.  It is used for specifying 

which account this ARS Route is 

applying. 

Plugin  The java class name for the plug-in 

Param  
The parameters which will be used by 

the plug-in 

Return  
The pattern of the value returned by the 

plug-in 

Deploy patterns 

From  
Specify replace patterns for From 

header using regular expressions. 

To  
Specify replace patterns for To header 

using regular expressions. 

Target  

Destination IP address. May omit entry 

when the destination IP address is 

specified in To header domain. 

Deploy patterns 

DTMF  

For when DTMF needs to be issued 

after calling gateway (2-stage calling), 

you can specify the DTMF string using 

some part of [To] Matching Pattern. 

Confirm  
Define voice prompt used with confirm 

call 

Key 5 Define confirm key entry 

Custom  Used for special occasions  

Parameters 

RTP relay default 

Select RTP relay ON/OFF.  

If “Default” is selected, [Option] menu > 

[RTP relay] (Unless specified at the 

User settings). 

on – RTP is handled by Brekeke PBX. 

off – RTP is not handled by Brekeke 

PBX. 

Codec Priority  
Specify codec to be use. Use a comma 

(,) when specifying multiple codec. 
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Block SIP 

INFO (DTMF) 
no 

Stop or not for passing the DTMF from 

a user to the other party when Brekeke 

PBX received DTMF 

Send RTCP off 

off - Brekeke PBX will not handle RTCP 

packets 

on – Brekeke PBX will handle RTCP 

packets 

Session 

Timer(sec, 

0=disable) 

0 

Interval to allow both user agents and 

SIP server to determine whether the 

SIP session is still active. 

100rel off 

Enable (on) / Disable (off) on using 

reliable provisional responses (1xx 

series) 

Next route on 

failure 
no 

Set failover for outbound sessions or 

not 

Parameters 

Disable on 

registration 

failure 

no 
Enable (yes)/Disable (no) this Pattern 

when registration failed  

Response 

timeout (ms) 
-1 

The period of time before timeout is 

activated when response has not been 

received 

Error codes 500 

Failover will be activated when 

specified error codes are received for 

INVITE requests 

Recovery time 

(ms) 
0 

The period of time till this pattern will be 

reactivated 

Disable on 

failure 
This route 

Disable this route when using this OUT 

pattern failed. Also can be set to 

disable one pattern in the ARS route or 

multiple ARS routes with the same 

group ID. 

 

Options: This route, This pattern, This 

group 
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7.5. Call Status 
The Call Status of ongoing calls is displayed under the [Call Status] menu. By specifying search 

criteria, the search result is displayed on the screen. You can view detailed information for the 

selected search result. 

 

Name Description 

Total Total number of system active sessions 

ID Call ID 

Status Call status: In progress, Talking 

UAs The users’ phone number in current session 

 

7.5.1. Status 

Name Description 

ID Call ID 

Status Call Status 

Call Park The number that has been parked 

Conference Conference number 

Start Time the call begin 

 

7.5.2. UAs (User Agents) 

Name Description 

User  User Name 

ARS Used ARS route 

URI SIP URI 

Connected Time the call begin 

Disconnect 
Disconnect the call. (If the user does not have rights to disconnect, 

this option will not be displayed. 

 

7.6. Call Logs 
Call Log information is available through Brekeke PBX. By specifying a date, you can view call 

log information for that date. By default, call log information is displayed in html on the browser, 

by clicking the [csv] button, you can download a log file to your local machine in .CSV format. 

Individual Call logs for each user are available under each user. 
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7.7. Notes 
The menu item is used by Brekeke PBX plug-ins to access text data or save script files for IVR 

script users. You can also use this for making some memos. 

 

Name Description 

Name Name of the note. 

Description A brief description of the note 

User access level 
Define if this note can be accessed by users and access level 

Select from “No Access”, “Read only”, “Read/Write” 

Note Text field where you can write your own notes. 

 

7.8. Extensions 
Click the menu [Extension] on the left menu panel. Select different extension tabs and create 

extensions. Click on extension ID to edit this extension setting. 

For user extension setting details, refer to the Brekeke PBX User Guide  

 

7.8.1. System Administrator 

Name Default value Description 

User Type Admin Administrator user  

User sa Default administrator user name 

Login Password sa Default administrator login password 

 

7.8.2. Group Extensions 

♦ Simultaneous Ring Group 

Name Default value Description 

Extension  Extension ID 

Type 
Simultaneous 

Ring 
Extension type 

Description  Extension description 

Group 

Extensions* 
 

User extensions’ ID to which Brekeke PBX will 

forward ring group call 

Separate user extension ID by comma 
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Ringer time (sec)* 90 

Ringer timeout for waiting for the recipient to 

answer. After the length of time set here, the call will 

be transferred to the destination that is specified in 

the [Forwarding destination (No answer)] field.  If 

no destination is set at [Forwarding destination (No 

answer)], the call will be terminated. 

Forwarding 

destination (No 

Answer) 

 
Destination to which the call will be forwarded when 

ringer timeout has occurred.  

 

♦ Call Hunting group 

Name Default value Description 

Extension  Extension ID 

Type Call Hunting Extension type 

Description  Extension description 

Mode Round-robin 

There are two modes for call forwarding.  

Round Robin: Calls will be distributed from the top of 

the list. When a call is received, it is forwarded to the 

extension following the last extension to have 

received a call.  

Top-down: Calls will always be distributed in the 

order listed in the field. 

Hunt group 

extensions* 
 

Enter phone number(s) to forward all calls that are 

received at this extension number. 

Ringer time (sec)* 20 

The awaiting time interval between Brekeke PBX 

rings each destination in [Hunt group extensions*] 

field 

Multiple time interval can be set and separated by 

comma, such as, 5.15.0.10 

With the setting, Brekeke PBX will ring first 

destination when there is an incoming call, and wait 

for 5 sec to ring the second destination, then wait 15 

sec to ring third and forth destination together 

because the third ring time is set as 0, then wait 10 

sec to ring next destination 
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Waiting time in the 

queue (sec) 
0 

The length of time for queued calls will be held on 

hold till forwarded to the user destination set at 

[Forwarding destination (No answer)].  

Max number of 

calls in the queue 
10 

The maximum number of calls can wait in the 

queue.  

Call interval 

(msec) 
3000 

The interval period for calls in queue to ring a client 

that end the call session.  

Single attempt no 

Enable/disable to retry calls when an initial try has 

not been answered. When this setting is enabled, 

the call will be transferred to the destination set at 

[Forwarding destination (No answer)] after initial try 

is not answer. 

Forwarding 

destination (No 

Answer) 

 
Destination to which the call will be forwarded when 

timeout has occurred.  

 

7.8.3. Schedule Extensions  

Name Default value Description 

Extension  Extension ID 

Type Call Hunting Extension type 

Description  Extension description 

Forwarding 

destinations* 
 

Destination phone number to forward all calls that 

are received by this extension. Calls will be 

forwarded to the appropriate destination based on 

conditions defined in the schedule. 

Conditions  
Specify schedule information by which to forward 

incoming calls. 

 

Name Description 

Default Forwarding Schedule* 

The call will be forwarded to the destination 

set here when all other schedules can not be 

applied to the call 

Forwarding Schedule [n] 

The call will be directed to the destination set 

in forwarding destination when conditions is 

fulfilled 
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Plan [n] 

Multiple schedule plans can be created under 

an extension 

The Plan showing active will be applied. 

 

7.8.4. IVR Extensions 

♦ Auto Attendant 

Name Default value Description 

Extension  Extension ID 

Type Auto Attendant Extension type 

Description  Extension description 

Max input digits 4 
Maximum number of input digits accepted by the 

Auto Attendant. 

Max retry count 5 

Maximum number of retries when an input error has 

occurred. After retries of the number of times set 

here, the call will be terminated.  

Ring timeout (sec) 30 
The length of time that a destination phone will ring 

when a call is received via Auto Attendant. 

Default operator  
Default destination (user extension number) for an 

incoming call that has not specified a call recipient.  

Speed dial*  

Set up “Speed dial” for Auto Attendant.  

Example: 0=0001. In this case, instead of dialing 

0001 to reach the user 0001, a caller can dial 0.  

Transfer to 

unregistered 

users 

disable 

Enables/disables call transfers to an unregistered 

user.   

Options: disable/enable 

 

Sound Files 

Name Description 

Greeting message 
Greeting message that is used for the Auto 

Attendant. 

Retry message 
A message to prompt the caller to reenter 

when an input error occurred. 

Music on hold 
An audio file that contains music/sound that 

will be used for music on hold. 
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♦ Add/Remove Forwarding Destinations 

Name Default value Description 

Extension  Extension ID 

Type 

Add/Remove 

forwarding 

destinations 

Extension type 

Description  Extension description 

Target groups*  By calling this extension, caller’s extension number 

will be added/deleted from [Group Extensions] field 

in group extension set in this field.  

 

♦ Switch Plan 

Name Default value Description 

Extension  Extension ID 

Type Switch Plan Extension type 

Description  Extension description 

Plan Number 2 

By calling this extension, caller user extension’s 

[Inbound] page active plan value will be changed to 

the value set here  

On/Off Yes 

When set as yes, plan number will be set as active 

plan when user call to this extension and active plan 

will switch back to plan 1 when call this extension 

again., 

When set as no, user active plan can only set to this 

plan number but cannot switch back to plan 1 no 

matter how many times call to this extension 

 

7.8.5. Conference Extensions 

Name Default value Description 

Extension  Extension ID 

Description  Extension description 

Forwarding 

destinations* 
 

By specifying user extensions ID, a user can invite 

multiple users to this conference by dialing this 

extension. 
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Applies to (Caller 

numbers) * 
* 

Restrict on caller that can dial in and join this 

conference.  

A star (*) and a questions mark (?) can be used for 

matching meta-characters. A star (*) means zero (0) 

or more characters and a question mark (?) means 

one character. 

 

7.8.6. Callback Extensions 

Name Default value Description 

Extension  Extension ID 

Description  Extension description 

Ringer time (sec) 90 
Ringing timeout before direct call to the forwarding  

destination 

Forwarding 

destination (No 

answer) 

 
The destination caller will be directed to when 

ringing time out 

Callback callee * 
The destination Brekeke PBX will connect caller to 

when caller disconnect call before ringing timeout 
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